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1.2 Installation

Please insert the Ludwig-DVD into your computer. Wait for the installer program to start
automatically. If the installer does not launch automatically run the program Setup from the
root directory of the DVD. 

Please click on Install to continue with the installation.

CAUTION: If your computer runs Vista or Windows 7 you will be asked to confirm
administrative rights for the installer after some time. Please do not leave the computer alone
during installation before you have not confirmed this.

As soon as you have started Ludwig you can open the program documentation by hitting the
key F1.

1.3 Program Activation

Activating the program will upgrade the Free-Version to the Premium-Version. This enables
features like printing and saving.

You can find the activation key on the front of the installation sheet in your DVD box.
Alternatively it will have been sent to you by E-mail. You can copy the key directly from the E-
mail (Cut&Paste), the entry form will automatically fill the input fields for you. In both cases,
you still have to enter the four control letters shown in the green box manually. 
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2 Overview - What Ludwig Can Do

Ludwig is an automatic composing software. Ludwig can generate accompaniments for
given melodies in a wide range of different styles. 
You can either input the tunes yourself, or load them from the database included with the
software. Ludwig can also compose its own melodies.
A unique capability of the program is that it writes out accompanying parts note by note,
following the rules of music theory. This creates rich melodic textures and sounds better than
the usual pattern based auto-compositions.

There are two types of accompaniment in Ludwig:

1. A band  accompaniment with one or more melodic parts and a rhythm section. The
band plays in a certain style like Pop or Jazz.

2. An ensemble  accompaniment for a given set of instruments. This is suitable for e.g.
domestic music, music tuition and simple choral works. 

Both types can be combined, so for example, a recorder trio can be accompanied by a
samba band.

Main Features:

Arranging tunes for a band 
Arranging tunes for an ensemble 
Automatic chords for a melody
Storing songs in databases

License-free music from popular melodies
License-free music from Ludwig's own tunes
License-free music for practicing instruments

Working with Ludwig:

I want to write a song
Singing with Ludwig
Ludwig in the classroom
Music at home
License-free music
I want to learn an instrument
I give music lessons
I want to practice improvisation
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2.1 Arranging Melodies for a Band

There are several ways to get a melody:
Enter notes using the keyboard and mouse .

Load a melody from the song database.

Enter notes with a Midi-keyboard .

Import Midi-data .

Before Ludwig can create an accompaniment you'll have to provide chords for the melody.
You can either enter these manually yourself  or, under Insert > Chords > Auto Chords,
simply let Ludwig do it for you.

Using the button  in the Start Tab you can create a band accompaniment for the current
melody in the melody editor .
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The buttons at the top of the dialog set a musical genre or category of styles (e.g. "Pop"). 

In the column on the left, you select a specific style.

The column on the right contains the arrangements and instrumentation available for that
style. Some styles have several arrangements. Ludwig lets you combine any style with any
arrangement, ("Show All"), however, arrangements are usually optimized for only a few
styles.
Some arrangements offer a choice of different instrumentations. You can vary them by
selecting "Instrumentation" from the list on the bottom right.

Each style has a suggested basic tempo (in BPM) that you can change here.

Styles are optimized for a certain meter ("4/4"). However you can use any style for any
meter. The style list shows the meter in red if it doesn't fit the current melody. Click Filter to
see only styles that fit. 

Related Topics:  Setting the Form of a Song , Special Arrangement for a Song36 40
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2.2 Arranging Melodies for an Ensemble

Using the button  (Start Tab -> Accompany With Ensemble), you arrange the current
melody for a small ensemble. 

For a start, ignore all parameter settings (part types) and simply select a preset from the list.

You can combine any melodic instruments into an ensemble. Click Add Instruments to add
any instrument to your ensemble. Click Delete to remove existing instruments.

You define the type of accompaniment and the degree of difficulty, and Ludwig will write the
part for the given instruments.

Types of Ensemble Parts

Melodic: The instrument plays the melody in its own register/range.

Harmony: A harmony-based accompaniment with sustained tones. Works well with choral
arrangements.
Coupled Notes: The voice is rhythmic and flows in the same direction as the melody. 
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Counterpoint: An independent melodic voice (counterpoint), which is heard quite distinctly.

Piano: A very easy piano part with accompanying chords. 

Bass: An easy bass arrangement.

Tips for choosing the types of Ensemble Parts:

Multiple pure coupled voices sound together well, because they are calculated together. 

Multiple pure harmonic voices sound together well, because they are calculated together. 

Counter-voices may be used together with harmonic voices, as Ludwig is aware of
potential dissonances.
When you're mixing coupled voices with other voices, you might sometimes get slight
dissonances. These aren't always audible, as coupled notes are difficult to discern for the
listener. Splitting the sopranos in choral pieces as coupled voices to get a five-part choral
arrangement generally works fine.
The accompanying voices need to be well-spaced in a melody. Transpose  the melody
higher, so the accompanying have enough range to "breathe" below the melody. This
makes most tracks sound better.
If a voice does not fit into the range of the given instrument, it will be transposed
automatically. Sometimes this sounds quite nice if a coupled voice appears above the
melody. Alternatively, you can transpose the melody higher to make space.
If you use four coupled parts, Ludwig uses tensions, creating a kind of big band sound.

When printing or playing from the screen, use transpose score  to ensure that parts for
transposing instruments like the Bb-clarinet get printed out correctly.

You can combine ensembles with a band accompaniment. Click for example on drum from
style, to add a drum accompaniment.
An ensemble can contain only one instrument. Add ensemble under style, so you can create
an accompaniment for just your instrument. 

Tip: If French Horns are the only coupled voice, set Ludwig to "Horn Fifths", so the parts
can be played on actual horns.

40
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2.3 Set Chords for a Melody

1. Automatic Chords

Ludwig can automatically provide chords for the melody in the melody editor: automatic
chords .

2. Entering chords manually:

Hold down the Ctrl-key and click on a note.

This opens an entry form for chord selection:

Choose a chord from the list of suggestions by double-clicking on it, or type your own chord
into the edit field. Click on the button Chord to play the chord. Click on Context to play it in
sequence with the previous and the next chord.

Modify or delete a chord in the melody editor by clicking on it with the right mouse button

Tip: to set more than one chord for a long note:
Right mouse click on the first chord -> enter the number of beats, then the chord. 

How to Edit Chords:

Enter new chord: Ctrl-click or right mouse click
on a note.
Alternative: Click on note, then
F6 Key.

Change an existing chord: Click on chord symbol above
a note. 

38
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Delete chord Right mouse click on Chord -
> Delete

Multiple chords on a long note Right mouse click on the first
chord -> enter the number of
beats, then the chord. 

Examples for Chord Syntax:

c C-min

Cm C-min

C C-Maj

B B-Maj

Bb B-Maj

Gm7b5 G-min 7 with diminished 5

C7maj C-Maj major 7 (In that order!)

Csus Csus4

C2 Cadd2

Gaug G-Maj with augmented 5

C#11 C#-Maj with 11

C_#11 C-Maj with augmented 11

Cs11
C-Maj with augmented

(sharp) 11

Gsus7 Gsus4 with 7

Gsus9 Gsus4 with 9

Abmb5
As-min with diminished (flat)

5

G0 Gdim7

Eb7s9 Es-Maj 7 with #9

Bbm6/F
Bb-min with 6 and F in the

bass

N/C No Chord 

F/C F-Maj, second inversion
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2.4 Storing Melodies in Databases

Ludwig doesn't store melodies as single files, it groups them together into Song Databases
.

A song database can easily manage hundreds to thousands of pieces.

The database lists let you see all the relevant information - the title, composer, year of
composition and country of origin - and much more, at a glance. 
You can save multiple versions of the same melody one after the other.

You can select several pieces from the database in one go, and arrange and play them
automatically. 

Click on the tab Start -> Melody -> Open, to open a song database.
Using the Start -> Melody -> Save tab, you can save the current melody. If this was originally
loaded from the database and you've altered it in some way, it will be replaced by the latest
version. For a newly composed melody, the program will ask you to choose the database
before it saves the data. 

Tip: To save a new version of a melody:
Applications Menu > Save > Save Melody Versions. In the database list, there's a
version column, which you can sort through by clicking on the titles of different versions.

Note: The song database only stores melodies together with style suggestions. It never
stores an accompanying score with a melody, because Ludwig generates this score on the
fly. If you want to save full scores, use Application Menu > Save > Score.

46
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2.5 Arranging Popular Songs

Ludwig comes with its own song database  named "PopularSongs.sngbase". After
installation, you'll find it in the folder Documents/Ludwig/Songbases.

To open the database, select Start > Melody > Open.

This database contains 480 well-known tunes, from Classical, Folk and Pop tunes, to
Christmas and Children's songs. They are copyright-free to our best knowledge. Ludwig's
own arrangements are also copyright-free. This provides you with a source of license-free
music.

Ludwig can play music infinitely long. The arrangements in the song database  tagged as "
Demo " pieces can be played in a random order for an indefinite length of time. Ludwig can
arrange a piece and play at the same time, so there won't be any breaks in the music. To
start this function, just click on Play > Inifinite Play > Popular Song Demo.

Tagging pieces as 'demo' in the song database

In the database list, select a piece of music and press Ctrl-D. The letter '"D" will appear in
the Demo column. You might have to scroll your list horizontally to see this column. For
tunes you've input yourself, set a Style Suggestion  first, then the style of the
accompaniment.

46
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2.6 Ludwig's Own Compositions

Ludwig can write and arrange its own songs using its own melodies. Select  Play > Demo >
Ludwig-Song:

You'll see that Ludwig-Songs are defined by parameters set out in four columns: the left hand
column is the style, then the rhythm material , followed by the chord material  and finally
the arrangement . Above them is the key signature, which will be chosen at random if this
is set to RANDOM.

Ludwig develops the melody from the rhythm material and chord material. They are
consistent with the general style. If the same settings are used, Ludwig will generate exactly
the same piece if the processing time and hardware are comparable. However changing the
scale key will produce a different melody.
The program generates the melodies note by note - it doesn't use a sequence of stored
patterns.
See also here: Ludwig Song

51 51

53

49



Ludwig 316

© 2011 ChessBase GmbH

2.7 Practicing an Instrument

Ludwig can't replace a music teacher. The program can however be a lot of fun for
beginners, by composing simple exercises for them. Ludwig writes simple melodies with a
pitch range easily playable for beginners. The rhythm is simple, and the tempo can be slowed
down as much as you like. The point is that you play an extremely simple melody with a very
rich accompaniment. Also you train sight-reading.

Click on the tab Play -> Practice Instrument. Then choose your instrument, level of difficulty
and style:

In Customize, enter a range of keys for the practice piece. With the style User, you can select
a free Ludwig-Song . Otherwise, it will use a piece chosen at random. 
You can slow the tempo down to suit the level of difficulty. You can adjust this with the tempo
controller at the top.

15



Overview - What Ludwig Can Do 17

© 2011 ChessBase GmbH

2.8 Writing a Song

Input a Melody

Enter notes in the melody editor . You reach the melody editor by clicking on the tab
Enter Melody directly above the score

Alternatively, you can input notes with your Midi-keyboard .

Set Chords

Chords can be entered by hand, using Ctrl-Click on a note , or you can let them to be
set automatically by Ludwig .

Repetitions and Form

The musical form (repetitions, verses) of your song is controlled by the storyboard .
The storyboard determines when which lines of the song are played, and what Drama
Stages  the accompaniment should use for them. With the Drama Stages, you
achieve contrast and emotional development in a composition. Not all repeated song
lines or verses should sound the same. If you do not provide a storyboard, Ludwig will
set one automatically.

Ludwig Composes an Accompaniment

Once melody, chords and perhaps a storyboard have been provided, Ludwig can 
compose an accompaniment . It only takes a few clicks to choose an accompaniment
style. Ludwig can either set your song for a band using a given style or for an ensemble
or a choir.

Song Title and Attributes

Click on the Tab Home > Melody > Set Title. Enter the name of the piece, the composer
and so on. You can even make an Style Suggestion . This suggests the
accompaniment style and instrumentation a piece should be played with.

Enter Lyrics

For songs, you can input the lyrics  as text divided into verses. If you already have the
lyrics typed up (or copied e.g. from the web), Ludwig can import them straight from your
word processor (Attributes > Lyrics > Paste Lyrics). However you need to hyphenate
syllables where necessary first.

Advanced: Create your own Arrangement

You can develop your own arrangement  for any piece. You can e.g. choose the
instrumentation. If you want to go even further, you can determine which instrument
plays at each Drama Stage , and how instruments should play together. A flute could,
for example, double the melody an octave higher, a trumpet could play small fills
between the phrases.

30
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2.9 Domestic Music with Ludwig

Load Melody from Database

The database supplied  with Ludwig contains a wide range of popular melodies and
well-known songs. This saves you the effort of having to input them yourself, or having to
download/import them all as Midi-files. 

Arrange for Small Ensemble

Create a small ensemble  of the instruments in your family. If you have mainly high
instruments at your disposal, or want to play rhythmic pieces, use coupled voices.
Alternatively, you can use harmonies, which are easier technically. If you play duets,
work out a piece using counter-harmonies. If you're mainly playing solos, choose an
Ensemble that only includes your melody instrument, and add a rhythm section and
accompaniment style.

Print Parts

Once you've made a track you're happy with, click on the Applications Menu >Print >
Print Parts to print the notation for any part in an ensemble combination.

Play from computer screen or projector

You can mix an ensemble with a band accompaniment . If you want to record an MP3
file, you'll have to play close to your computer. Then you can follow the notation on
screen: switch to Notation > Options > Score Type > Part Notation.

14

9

7
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2.10 Ludwig for Music Lessons

Play easy tunes at sight

Use the instrument practice  function to create easy pieces to train your sight reading
capabilities. Even a complete beginner can achieve a sense of achievement when
playing with a full band.

Generate a Play-Along MP3 

You can input any well known piece, and record an accompaniment  that you can
replay at a slower tempo, and use it afterwards as an MP3 ("Play-Along").

Play simple two-part pieces with your student

Use the ensemble  function, to create simple accompaniments which you can play
with your student.

Practice Improvisation

Improvisation is one of the most popular uses for computer-based accompaniment. The
function Practice > Improvisation  supports this. Ludwig creates a new piece with a
32-bar theme, then performs it once. After that, the theme is repeated one or more times
and you can improvise over it, using the (muted) melody on screen for inspiration. 

Interactive Session

With Ludwig, you can practice playing eight bar themes  on a Midi keyboard. The
interesting part is that the program responds in real time, and adds variations to these
themes with its replies.

16

7

9
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2.11 Ludwig in the Classroom

Generate MP3 accompaniments for singing in class

If you want to sing a song with your class, you can create an accompaniment with
Ludwig. If the class has access to a computer, you do not need to save it as MP3 or CD,
you use Ludwig directly. You can also adjust the tempo of the accompaniment when
you're practicing or rehearsing a piece of music. 

Simple Arrangements for Recorder

Ludwig can write simple arrangements for two recorders. If the children have a
reasonably good mastery of the recorder, you can use coupled voices, otherwise use
harmony voices that are simpler technically. With older children whose hands are big
enough, we recommend the combination of a Soprano and a Tenor flute. Plastic tenor
flutes are fairly inexpensive, and are played like a soprano flute, so children can learn to
play them quite quickly and the combination of a a high and a low flute is quite pleasing.

Print Parts

Go to Application Menu  > Print > Print Parts to print the notation for each part of your
ensemble.

Print Song Lyrics

Use Attributes > Lyrics > Copy Lyrics, to copy the complete lyrics of the loaded song for
further editing in a word processor.

Arrange for School Band

The ensemble  "Big Band Horns" creates simple voicings for a school band. If you
don't have a five-part brass section, just delete out any surplus part. However only for
five or more parts will Ludwig use tensions in the voicings to create the characteristic
Big Band sound. You could also add a bass (Voice Type = Bass, Skill Level = Easy).
This creates a very simple bass part, which can be given to a young bassist. 
Similarly you could add a very simple piano part. 

Arrange for a Small Orchestra

The ensemble  "String Quartet" or "String Trio" will give you a basic three- and four-
part classical voicing.

26

9

9
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2.12 Singing with Ludwig

Generate MP3 accompaniments

You can compose your own melodies, load them from the accompanying song
database  or import a Midi-file  from the web. Then you create your own
accompaniment  for it. For songs from the song database, you'll be given a Style
Suggestion  for an appropriate style.
Select Applications Menu  > Save As > MP3. In the record audio window, click on
Record. Once you've finished recording, you click on Save (MP3).

Choral Arrangements

Ludwig can write two to five part choral arrangements. For a particular melody, select 
tab Home > Accompany > Accompany with Ensemble. From the list of ensembles,
select one of the choral entries. The letters used - S, A, T and B - stand for Soprano,
Alto, Tenor and Bass respectively. "C" stands for Cambiata - this is for an adolescent
boy's voice, and has a narrower range. 
Because the internal Ludwig voice sounds cannot articulate single syllables, Ludwig by
default merges syllables to longer notes in the harmony parts. This enables the choir to
sing, for example, "Uuhs" or "Aahs" in the background. If you want single syllables in all
the voices, tick Rhythmic Syllables beneath the ensemble selection.
The choir parts can be combined with a band accompaniment ("Style"), to create
training-MP3s ("Teach-Me's") for your choir.

Tip: For very rhythmic pieces, choose coupled voices for e.g. S, A, A, T, B, to
produce a modern ("jazzy") vocal style with slight dissonances. Experiment with high
coupled voices and low harmony voices. The resulting timbre is found in many popular
arrangements, in which the males e.g. would sing a "Dum" or "Bom" bass line while the
female voices mimic a coupled brass section.

Set Notation > Transpose Score, so the correct clef is used for individual voices.
Experiment with transposing the melody to higher and lower keys. 

Sing From Projector

Load a song with lyrics from the database and create an accompaniment. Turn the
score to large (F9 key or View > Standard Layout > Score only). Select Score > Score
Type > Select Parts, and select the melody voice for display. Now you can sing along
with the accompaniment using a projector or video screen.

Tip: If the choir is good at sight-reading, you can produce an ensemble for choir
S + B. In the S + B ensemble, the bass only goes down to low A, so also a Tenor could
sing this part.

13 43

7
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2.13 License-Free Music from Ludwig

Create background music of given duration

Using the tab Play > Demo > Ludwig Song , you use Ludwig to generate a piece of
music in a given style. By combining arrangement and tempo control, you can control
the duration of the song. 

Arrange Popular Melodies

You can load well-known classical pieces from the included Song Database , and
arrange them using new styles to create fascinating musical pieces for you to use.
Classical music arranged in Latin styles usually works well.

Background Music in a given Style

You can take well-known melodies in a particular musical style, copy them into a Song
Database , then, using the Play > Infinite Play > Select SongBase, switch between
these demo pieces  in a random order, and rearrange them in different keys.
With Play > Infinite Play > Ludwig Songs, you can play background music using
Ludwig's own compositions in a wide range of styles.
Alternatively, you can create your own play list of Ludwig songs, and play them using 
Play > Playlist > Play Playlist.

49
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2.14 Improvisation with Ludwig

If you input the chord changes of a Jazz Standard without a melody (i.e. simply set chords
over full bar rests), you can use this to improvise over. Alternatively, of course, you could
simply mute all of the melody parts from a piece of music by using the mute switches in the
mixer window. 

There is also a special function for interactive improvisation based on Ludwigs own songs:

Go to Play > Improvisation.

Ludwig-Songs support improvisation over a given melody: after calling up Practice >
Improvisation, then choose any Ludwig-song .

Ludwig plays the theme first with the usual melody instruments of the style. Then the
program goes into a loop, in which the melody is muted, an you can improvise over the
chords. The melody still runs on the screen. If you're a novice at improvisation, you can
practice embellishing the melody. Click on Song End, if you don't want any more loops to
follow.

If you're playing along with a bass, you can mute the bass voice as well for the loops. 

49
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2.15 Demo

For a quick demo of Ludwigs arranging/composition cababilities, try one of the following:

Popular Melodies

Select Play > Infinite Play > Popular Song Demo. This lets Ludwig arrange pieces from
the included song database automatically for an infinite time (until you click stop).

^
The choice of pieces is completely random. So if you dont like a piece, just press Skip to
get to the next one. There is a wild range of styles, from classical pieces and children
songs to Rock gospels.

Infinite Play in a given Style

Select Play > Infinite Play > Ludwig Songs, and choose a style from the menu. Ludwig
can write its own pieces using its own melodies. The program will compose in the
background while it plays the current score in the foreground.

Ludwig-Songs

You can let Ludwig compose its own songs in just five simple clicks using the tab Play >
Demo > Ludwig Song.
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3 List of Functions

3.1 Ludwig's User Interface

Window arrangement:

To change the size of the window, click the mouse on the divider between the two windows,
hold the mouse button down and drag the divider:

If you want to move a window to another place, click on the grey top bar, hold down the
mouse key and drag it to another position. When you release the key, it will jump to its new
location. Try it out. Very little can go wrong, because you easily revert to the default layout by
simply pressing the F9 Key.

Hide Window/Restore Window

Tab View > Window Area turns the window on or off:
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3.1.1 Applications Menu

The Applications Menu is situated at the top left of the Ludwig Menu Ribbon. Click on the
circular green button containing the white note: this combines all the functions for opening
and printing.
On the right side of the Applications Menu, you see the most recently loaded melodies; so
you can open them with a single click from here. 

3.1.2 The Mixer Window

The mixer window allows you to select instruments and modify their volume.
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To change the instrumentation, click on an instrument symbol.

The Loud ("L"), Solo ("S") and Off ("M" for Mute) switches work somewhat differently than in
other programs: they have a toggle-function, i.e. clicking on them twice restores the mixer to
its original state. So, for example, if you click on the 'Loud' switch for three instruments, and
then click on any one of them for a second time, all instruments will return to their original
volume. 

3.1.3 Score Functions

Use the scroll bar beneath the score to move through the pages. A page of the score usually
contains four bars, that is one melody line. 

Keyboard Navigation:

Scroll Up/
Down or
Arrow Keys

Page backwards/forwards

End Last page

Pos1 First page (after count-in)

Space Bar Start playback

Shift + Space
Bar

Play a line
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Esc Stop playing smoothly ("Fade Out“)

Enter Create an acompaniment for a melody (overwrite score)

F9 Toggle between full screen score and standard layout

Playing Sections of Pieces

Four Bars,
Full Score

Click on 

An
instrument
line

Click on the instrument symbol on the left, or the clef of the associated score line.

A bar for an
instrument

Click inside the bar

Two bars for
an instrument

Ctrl-Click in the first bar. 

One bar, full
Score

Shift-Click in the bar.

Two bars, full
Score

Ctrl-Shift-Click in the first bar.

Two or more
lines played
together

Ctrl-Click in the first (or one of the other) line, then click once in the second (or one of
the other) lines. 

If you check Home > Repeat, the section you've selected will be repeated indefinitely until you
press the Esc-Key or click Stop. This is so you can practice, or listen to the individual voices
using the Solo button in the Mixer. By repeating four bars over and over again, you can
generate a short vamp to improvise over. 
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3.1.4 Transposing Scores

Tab Notation > Options > Transposing Score

Every voice in a score is notated as required by the associated instrument. The B-clarinet, for
example, for historical reasons sounds a whole tone lower than it is written. So the notes are
transposed in the score and written a tone higher. Saxophones and Trumpets are
transposing instruments as well. 

Before you print  an excerpt from a score for a transposing instrument, switch to
Transposing Score so the output is correct that particular instrument. 

Normally, you'll be shown the entire score in C, that is non-transposing.

86
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3.2 Melody Editor

Start a new melody with the tab Home > Melody > New.

Start by supplying a time signature  and a key . You can change the key later at any time.

Ludwig has two notation displays, the score and the melody editor: the score displays the
generated music (accompaniments). Notes cannot be changed there. In the melody editor
you can input and edit a single, monophonic melody with chords and lyrics.

Ludwig's automatic arranger progresses line by line. By dividing your piece into melody lines,
you decide what form your music takes. In conventional notation programs, the division of
lines into bars is arbitrary. In Ludwig however, each melody line is treated as a unit of music
or phrase. Ludwig has to understand where you want the logical breaks in your song form. A
line has two to eight bars, but usually, there are four. 90% of Western music is based on four
bar phrases, whether you're dealing with a Pop song or a Mozart symphony. 

Use the function storyboard  to specify repeated lines or verses. So it is not necessary to
duplicate them in the melody editor.

Enter notes
Copy, paste, delete
Enter lyrics
Save melodies

Print melody

Navigation in the Melody Editor:

Left/Right Arrow To the next/previous note
value

Page Up/Down Scroll page by page

Pos1/End From the top to the end

Ctrl-Arrow Right/Left Jump from bar to bar
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3.2.1 Setting the Meter

In Ludwig, the metre (time signature) is set for the entire melody. You cannot change the
metre in a piece.

Click on Metre and use the drop list to select one of the available metres. You may also use a
pick-up. 

Ludwig's accompaniment styles are optimized for particular time signatures. Still you can use
a March-style to accompany a Waltz in 3/4-time, and the style will be adjusted accordingly.
Sometimes this sounds quite convincing, but not always.
In the selection dialog for the Band accompaniment, when the entries in the Meter column for
style are shown in red, the style does not fit the current metre in the melody editor. Try it
anyway, it might sound interesting.
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3.2.2 Key Signature

When you enter a new melody, Ludwig will ask you for a key signature. You can change it at
any time.

If you change the key under Attributes > Key Signature, this can be done with or without
transposition:

Click on No if you want to change the key, but not transpose the notes.

Tip: Us ing the key com bination  Ctrl-Sh ift-Arrow  up/down, you  can  sh ift the en tire m elody up
or down a half tone w ith  the correct transpos ition . Th is  is  usefu l, for exam ple, if you  want to pu t the
m elody in  the righ t range for a particu lar in s trum ent qu ickly.
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3.2.3 Inputting Notes

Entering notes via the computer keyboard is quite simple, and fairly easy once you've
mastered a few basic steps. Once you've got the hang of doing it by holding down the Shift-
key, you can almost input blindfolded. Of course, if you have a keyboard with a Midi port ,
this is even more convenient.

Select a note either using right arrow key on the keyboard or by clicking on it. The note you've
selected will be shown in green, the selected bar in light blue.

Key Function

1, 2, 4, 8, 9, 0 Change the value of the
current note: whole note, half
note, 1/4, 1/8, 1/16, 1/32.

3, 6 Set triplet value (quarter or
eighth note triplets).

c, d, e, f, g, a, b Enter a pitch, the accidentals
will be set to the current key
automatically.

Arrow up/down Pitch increase/decrease

Ctrl-Arrow up/down Displace pitch by an octave.

Shift-Arrow up/down Pitch for entire bar

Ctrl-Shift-Arrow up/down Pitch for entire piece

Shift-Alt-Arrow up/down Shift the previous note by an
octave (handy for inputting
notes while holding the shift
key).

Arrow key left/right Jump from note to note

# Increase the note value by
half (set a sharp)

l Lower the note value (set a
flat or 'b'). Mnemonic: "L"
from the English word "Flat".

n Delete accidentals for note.
Mnemonic: "n" from the
English "Natural".

. Dot the value of the selected
note.

44
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Key Function

: Note value dotted quarter.
Alternative to entering a '4.'

Shift + 4, 8, 9, 0. Set the values of the next four
notes (four 1/4 or four 1/8 or
four 1/16 or four 1/32).

C, D, E, F, G, A, B, C Enters the note with a pitch
and current value, then move
forward automatically. Saves
pressing the right arrow key.

p Change current note into a
rest.

F6 Set a chord at the selected
note

Ctrl-. Staccato set/delete

Ctrl-E Fermata set/delete

General remarks about inputting notes
Copy, Paste, Delete

30
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3.2.4 Copy, Paste and Delete in a Melody Entry

The Tab Insert contains most of the functions required for editing a melody. 

Use Copy Line -> Paste to duplicate single lines.

If you delete a bar (Insert > Line> Delete bar) or insert a blank bar, you can use a "Line
Wrap". This leaves the number of bars in a line the same and shifts a bar to/from the next
line. If you insert/delete a bar without line wrap, the line length will be altered.

Keyboard shortcuts for editing:

Ctrl-C Copy line

Ctrl-B Copy bar

Ctrl-V
Insert Bar/Line. Inserting bars
overrides the existing bar.

Ins Add empty line

Ctrl-Ins Insert empty line

Ctrl-Del Delete line

Strg-Z Undo

s Repeat bar (sequencing)

r Repeat note (repeat)

Ctrl-H Set chords automatically

Ctrl-Shift-Alt-H Delete all chords

Ctrl-Alt-L Enter lyrics

Ctrl-Shift-Alt-L Delete all song lyrics

Ctrl-N Enter a new melody
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3.2.5 Setting the Song Form with the Storyboard

Open Home > Melody > Storyboard to set the repetitions and form for your songs:

This storyboard contains six song lines (A, B, C, D, A1, B1) and generates a piece with 20
lines. Each line of the melody you enter is named, usually with a letter of the alphabet - A, B,
C etc. You can change these names by clicking on them at the end of the line:
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In the storyboard, by right clicking in the Name column, you set which line will be played at
that point. By right clicking under Drama you set the Drama Stage . This achieves contrast
and emotional development in your arrangement.

You can generate a storyboard with varying drama stages automatically by clicking on 
Automatic. If there are multiple verses in the song lyrics the storyboard will be filled with as
many repetitions as there are verses. 

You can copy/paste lines in the storyboard using the keyboard: Ctrl-C and Ctrl-V. Select more
than one line with Shift-Arrow, then either copy or delete them.

59
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3.2.6 Automatic Chords

Ludwig can automatically harmonize a melody with chords. 

Select tab Insert > Chords > Auto Chords:

The Mode slider controls the relative frequency of minor and major chords. Move it to the right
to get more major chords.
The Chord Variety slider determines the density of the chords and the different chord types.
For a simple children's song, we recommend a setting more on the left: try it out for yourself!

When Jazz is selected, chords with extra notes (for example, Major7-forms) will be used.

3.2.7 Entering Lyrics

In the melody editor, click on a song line. Select Attributes > Edit Lyrics. Enter the lyrics
corresponding to the melody line. Use the following control characters to distribute syllables:

 - (Hyphen): Separate syllables (can be used several times in a row)

_ (Underscore): Can be a word or a syllable. (can be used several times in a row)

0 (Zero): Skip a note (usually a pause at the beginning)



List of Functions 39

© 2011 ChessBase GmbH

Use the "Add Verse" button to add more verses to a song.

If you already have lyrics typed up from another source, you can add them to your song with a
single click. You must however, hyphenate the syllables using the above characters in
advance. You also have to us blank lines to separate verses.

Copy the song lyrics in your word processing software (Windows Notepad e.g. is fine), then
go to Attributes > Lyrics > Paste Lyrics.

Tip: If the song is already stored in the song database, you can use the web search
function of the database window to find the lyrics for public domain songs.

Example of insertion of prepared lyrics:

Frè-re Jac-ques, Frè-re Jac-ques, dor-mez vous, dor-mez vous?

Son-nez les ma-ti-nes, son-nez les ma-ti-nes, ding, ding, dong, ding, ding, dong.

 

Are you sleep-ing, are you sleep-ing, Broth-er John, Broth-er John?

Mor-ning bells are ring-ing, mor-ning bells are ring-ing, Ding, ding, dong, ding, ding, dong.
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3.2.8 Increasing or decreasing the pitch of a melody

Tab Attributes > Key Signature > Melody Higher/Melody Lower.

The quickest way to transpose a melody is to use this function to increase/decrease the pitch
by one semitone at a time.

If you're creating a piece for ensemble , where several voices have about the same range,
the range of the melody is quite important. Examples are flute or soprano voices, which can
get in each other's way if the melody range is too low. Set the melody as high as the range of
the highest instrument will comfortably allow. This frees the other voices from being
squeezed into a narrow range and it allows them a more independent development.

Otherwise, as a stopgap, Ludwig will simply transpose the accompanying voices one octave
over the melody which might or might not sound ok.

Another use for this function is to lower the pitch of a melody in the database if its highest
notes are not comfortable for singers.

3.2.9 Local Arrangement for a Song

Home > Melody > Arrangement.

This function is a shorter (and therefore more convenient) form of:
Home > Melody > Set Title > Style Suggestion > Arrangement: See also: Style Suggestion

.

Each piece can be equipped with its own special instrumentation. This is stored in an 
arrangement , which is saved together with the song. This arrangement defines when and
which voice is played, and how the voices play together in the accompaniment. In this way
you can creatively arrange your own song.

If no arrangement has been created for the song, this dialog box will appear:

9
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Always work with a copy of a standard arrangement to begin with, then you'll have a good
starting point.

It's recommended to use your own arrangements initially purely for instrumentation.
Later, you can try out different combinations of voices at the various Drama Stages .
Eventually, you can experiment with the various forms of accompaniment (Duet, Counter,
Fills, Note vs Note, etc.).

59
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3.2.10 Enter Title Data

Home > Melody > Set Title (F2 Key)

To find a song in the song database , you use the title data. You can search and sort the
database using either the title, the composer or the lyricist, etc. For search purposes, its
worth noting that in the entry field, for a composer or lyricist, their surname is on the left, and
their first name is on the right.

Using the Style Suggestion  button you can specify the style  and arrangement  which
should be used to accompany this melody. 

46
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3.2.11 Midi-Import

The Internet gives you access to an enormous range of free public-domain music in the form
of midi-files. Most professional notation software programs can export midi-files too. Ludwig
imports midi-files with all tracks. The program will try to identify the track containing the
melody, then import it into the melody editor for further editing.

Midi-files normally don't contain chord data. Ludwig therefore detects harmonies if there are
enough tracks to complete chords.

Note: Midi-Files with changes in the time signature are not always processable. Ludwig
cannot handle meter changes.
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3.2.12 Inputting Melodies with a Midi-Keyboard

Tab Input > Midi-Keyboard-Input (Ctrl-Alt-I shortcut).

If you can play the piano reasonably well, it is practical to enter notes using a Midi-Keyboard.
You'll need a MIDI keyboard with its own sound generator because the latency of Ludwigs
software synthesizer is unfortunately too high for precise input.

Insert the "Midi-In"-jack of your USB-Midi-adapter into the "Midi-Out"-jack of the keyboard.
Output data from the keyboard will then go to the Input port of your computer.

First, check your connection: the rectangular box above the Midi Input dialog box should be
green when you're playing the keyboard - if it isn't, no data is arriving. 

Input is carried out line by line. Start inputting data in units of four or eight bars. Click on start
input, listen to the metronome, and start entering data in sync with the correct bar beats.
The first beat of a bar sounds like a triangle. Beware when using a pick-up meter, you have to
start on the pick-up beat then. Set a slow tempo, so that you play the rhythm more precisely.
If the piece of music is rhythmically straightforward, switch off triplet and sixteenth note
detection if you want to make Ludwig tolerate minor inaccuracies.

With practice, you can enter a short piece in one single run. Ludwig will try to divide the piece
into reasonable numbers of bars, working from the rhythmic breaks and symmetry in the
melody. Note that splitting of a tune into melody lines is not arbitrary. The ends of melody
lines should coincide with logical breaks in the song. Ludwig can then apply proper
transitions, fills and phrase endings when writing the accompaniment.
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With Midi-Input, new lines will be attached at the end of an existing melody, so to start from
scratch, call Home > Melody > New first.

Here's how it works:

Click Start Input.

Start at the correct time point (usually the first bar). It is no problem if the metronome plays
several empty bars before you start entering notes.
Play a line, concentrating on rhythmic precision.

Click Save Line To Score to append your input to the current melody.

Repeat the process for each line (or set of lines).

Pay attention if you use a time signature with pick-up: With a 1/4-count-in, in 4/4-time
you have to start playing on the fourth beat of the bar. Listen to the triangle sound denoting the
first beat in a bar.
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3.3 Song Database

3.3.1 The Song Database

Ludwig does not save melodies in individual files, but stores them in Song Databases. This is
convenient for large collections of Songs. You can open any Song Database via Home >
Melody > Open (Ctrl-O):

You'll see a list like this:

Use the mouse or the arrow keys to select a piece.

Load a song by double clicking on it, or using the Enter key. 

You can sort a list of songs by clicking on the title column.

Move the column headers with the mouse, or right click in a column header to configure the
columns. 
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Search for a word in the title data using Home > Edit > Search Pieces.

Column Title Comments

Number Sequence number in the database

Title Song title

Composer

Direction Music direction, e.g. "Christmas"

Key

Tempo Metronome

Meter Time signature

Modified Date of last modification.

Style Style from Style Suggestion .

Demo "D" = Indicates a Demo Song .

Arranged Stored with its own Arrangement .

Arrangement Arrangement from the Style Suggestion.

Album

(C) Copyright; "OK" = song is in the public domain.

Year Year when the original was released.

Text With Lyrics .

Poet Name of Lyricist

Size Size of the Melody in bytes.

Version Whenever you replace/save the song this increments by one.

Prot. Protected = Protected. Protected from alteration or deletion.
Remove protection with Ctrl-P.

The Del key is used to mark songs out as deleted. They appear crossed out in the list. If
you use the tab Database > Delete Items, the piece will disappear from the database. The
Delete flag can be removed by pressing the Delete key again.

Right clicking on a column title opens the menu for configuring the columns in the song
list.
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3.3.2 Demo Piece

Press Ctrl-D to mark a piece in the Song Database  as Demo Piece. Ludwig can play
music infinitely by randomly arranging and playing entries from the Song Database. Only
entries marked as Demo Pieces will be used. Demo Pieces should have a Style Suggestion

 so that Ludwig knows how to arrange it.

You can use any Song Database for playing Demo Pieces from it: Tab Play > Infinite
Play > Select SongBase

If you don't like particular entries in the PopularSongs-Database, you can use Ctrl-D to turn
them off so they aren't used in Demo mode.

46
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3.4 Ludwig Songs

3.4.1 Generating Ludwig Songs

A Ludwig-Song is a piece for which Ludwig writes the melody itself. This can be used to
create license-free background and other function music.

Go to Play > Ludwig-Demo > Ludwig-Song.

Choose the four columns in the Composition dialog: Accompaniment Style , Rhythm ,
Chord Material  and Arrangement .

With some arrangements your're provided with alternative instrumentations, that you set in
the top right: 

59 51
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Ludwig Songs can have Short Versions. The length and form of a Ludwig song is determined
by the arrangement.

If you edit an arrangement  (your create your own derivation), you can set the form as
sequence of drama stages  here:

In the above example, the long version repeats the block "Calm, Calm2, Norm, Norm2" once
before entering the final emotional build-up. Four form parts are usually 16 bars in Ludwig
songs, so the long version is 16 bars longer.

53
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3.4.2 Rhythmic Material for Ludwig Songs

When Ludwig composes its own songs (tab Play > Demo > Ludwig Song or Tab Play >
Infinte Play > Ludwig Songs), the program uses predetermined rhythmic material. This
material is from the Song Database, which you can find in Documents\Ludwig\Rhythm. 

Ludwig varies these rhythms according to the Style to some extent, but generally stays within
the specifications. Rhythmic material is labeled with an adjective, whilst Chord material  is
labeled with a noun, which produces simple song titles that make it easy to reproduce a
Ludwig Song once you like it. 

Examples of Ludwig Song titles:

Elegant Jeans
Shining Aurora
Plucking Apple

If you change the key of a song (e.g. C major to D major) and keep all other parameters
identical, the melodic line will usually be quite different.

Changing the key of a Ludwig song:

3.4.3 Chord Material for Ludwig Songs

For its own songs (tab Play > Demo > Ludwig Song or Tab Play > Infinte Play > Ludwig
Songs), Ludwig uses certain fixed harmonic material. This is stored in a song database. You
can find this song database under Documents\Ludwig\Chords. The chords are stored as
individual pieces that you can add to and edit. They are all tagged with musical genres . So
you can write melodies using a particular type of style. 

Ludwig often makes substitutions when using those chords. A substitution replaces a chord
by an alternative one. But the program more or less sticks to the give set of chord changes. 
Rhythmic material  is labeled with an adjective, chord material with noun: this produces an
easy-to-remember song title.
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3.5 Styles and Arrangements

3.5.1 Style Suggestion

Tab Home > Melody > Enter Title > Style Suggestion

For any song, the style suggestion function can recommend a particular style and
arrangement for the song to be accompanied with. This can be an existing style or
arrangement. You can also define completely new arrangements , and store these
embedded into the song in the song database . You could even define a new style only for
this song, but this would go very far.

New Instrumentation for a Piece of Music

This is the most common use for the style suggestion:
Click on New Arrangement.

Select Copy Existing.

40
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In the arrangement editor  you click left on Band, and then, for example, on Melody. S
imply change the instruments there.
Now click OK successively to shut all dialog boxes.

Save the changes you've made to the song (which now incorporates the style suggestion).

You can always quickly acces the new "local" arrangement  by pressing Home >
Melody > Arrangement (Keys Ctrl-Shift-A).

3.5.2 The Arrangement

An arrangement provides instrumentation, form and emotion for a piece of music. You use
the storyboard  to set drama stages  for your song. 
The arrangement determines which instrument should play at which drama stage. For a
given style  there can be several different arrangements providing you with a variety of
accompaniments. A Fast Swing can be played by a Big Band, but also by a small Trio. The
rhythm section is derived from the style, and would be the same in both cases. The
instruments used to play the melody however, could be completely different. 

You can edit existing arrangements as well as create them. It's relatively easy to change the
instrumentation for a piece of music in a given arrangement. But it doesn't stop here: You can
also change how the different instruments play together, who has the lead melody and who
accompanies. 
For example, you can have an instrument just playing the tune, or double the melody an
octave above or below. Or it might play an independent counter line or a guide line. Ludwig
offers many choices for accompaniment techniques, thus enabling you to take an active and
creative part in the resulting compositions.

How you to edit arrangements

3.5.3 Editing Arrangements

To create a new arrangement, go to Applications Menu  > New > Arrangement .
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The start page for a new arrangement looks like this:

You need to assign a unique title for an arrangement (one that hasn't been used previously). 

Tempo Offset will be be added to the default tempo of the piece, and can also have
negative values.
Swing is a setting for Swing-Rhythms with eighth notes. This overrides any swing settings
in the style. So you could even play one of the Jazz-styles straight (well, better forget about
that).
With Reverb you set the reverb for the style. The Reverb Time is the time until the first
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reflection arrives at the listeners ears. Reverb Mix controls the strength of the effect.

If you select Band in the upper left hand corner, you see the entries:
Melody

Rhythm Section

Accompaniment

Here you can set the instruments for the melody parts, the Rhythm section (Keyboard,
Guitar, Bass, Drums) and the accompaniment parts (phrases, background). Don't overcrowd
your arrangement with too many voices, clarity is an aesthetic factor.

Under Drama you select what instrument is playing at which Drama Stage .

Here, in the drama stage Normal, the flute and the alto sax play the melody. The flute doubles
the melody an octave higher.

For each voice, you have three drop lists: 
The type of accompaniment , the parameters, additional parameters to the
accompaniment type and the line division. Usually, an instruments alway plays the full line.
However, if you select e.g. "H1" in the third drop list, it would only play the first half (usually
two bars). If you select "B4", it will only play the last bar ("Bar 4").

An arrangement can contain several parallel instrumentations. Those instrumentations
will appear in the accompaniment  dialog box. To add an alternative instrumentation, click
on Band and then on Add Band.

 A drama stage can be arranged differently whenever it repeats. This creates variety in
long pieces where one drama stage is repeated several times. You can safely ignore it for
small forms. Click Drama, and then Add Drama Repeat.

Right clicking on the voice type brings up a menu, which enables you to activate/
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deactivate a voice globally:
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3.5.4 Types of accompanying parts

When you're editing an arrangement , you can assign different accompaniment techniques
to a voice:

Click on the first drop list right besides the instrument name the in the arrangement-editor:

Here you see the available voicing types for the voice called "Double", played by the alto sax.
Each voice is identified by a fixed name ("Double", "Filler"), corresponding to its default
function. The Double part normally doubles the melody. However, it can play any other form
of accompaniment which you select in the drop list shown above.

Default

This plays the melody in unchanged form. It has no further parameters. Internally seen
as the main melody voice.

Doubling

Doubles the melody voice: doubling the melody is a simple but effective technique in
arranging. The doubling can also be located an octave above or below the melody.
Parameters include VA (an octave higher, e.g. flute), VA16 (two octaves higher, e.g.
piccolo) and VB (an octave lower, e.g. trumpet or cello).
You can double the voice in itself so that it will become two parts in one: the parameter
"VA, VB" results in a VA-octaved voice, which is doubled an octave below. 

Counter

An independent counter part (counterpoint). Rhythmically and melodically clearly
distinguishable from the melody. This creates interesting contrasts. It makes sense to
assign two parts to play counter, so that it is strong enough to be heard among the main
melody voices.
Parameters: Full for full notes, Half for half notes, Simple a simple melodic rhythm,
Complex an ornate melodic rhythm.

Note vs Note

A special type of counter voice: the pitch line is very independent from the main melody,
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but follows it rhythmically note by note. Leads to interesting effects if the voice is higher
than the melody ("OK, VAAUTO").
Other Parameters: Duet - the voice is doubled by a coupled voice. Creates more
complex polyphony, but can cause some dissonances.

Counter Voicing

Same as counter, but reinforced by two- (Duet) or three- (Chords) voices. Rich sound,
but can produce dissonances.

Guide Line

A special counter-line in full or half notes, which prefers to move in steps and
emphasizes the thirds or sevenths of the chords. Frequently used in Jazz.
Parameters: Full Below = whole notes below the melody, Full Above = whole notes
above the melody, Half Below/Above = half notes above/below the melody.

Riff

Plays the "Riff" defined in the style (you may ignore this).

Duet

Plays the melody together with an underlying coupled voice. A coupled voice is very
similar to the melody in rhythm and shape, which is why it is almost indistinguishable.
Parameter: 0 = only play the lower voice. 0, VA = only play the lower voice, but an
octave higher. 

Chord Voicing

Plays the melody together with two underlying coupled voices. 
Parameters: 0 = optionally play only the lower voice. 1 = only play the middle voice. With
those parameters, you can split the two coupled voices into two different instruments,
and produce a richer sound. 

Chorale

Four part chorale voicing. Useful for choral arrangements or realistic harmonic
backgrounds. 
Parameters: A, T, B = Alto, Tenor or Bass voice playing in the melodic rhythm.
A, leg, T, leg or B, leg = repeated notes are sustained, which leads to more natural
sounding voices.
A, pad , T, pad or B, pad = as little movement of the notes as possible, intended for a
pure background. 

Phrase

The four phrase voices (which usually contain pattern stuff) from the accompaniment
style.

HornQ

The melody is doubled with horn fifths. Old fashioned coupling that has its origins in
natural horn voices. Works well for Hunting- or Military music.

SAB

Similar to a Chorale, but with three voices. See Chorale above.

Section

Horn section with moderate dissonances, gives a kind of big band sound.
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List of Parameters used in the Octave Abbreviations

Abbreviati
on

Meaning

VA An octave above the actual voice/melody

VAAUTO An octave higher, if not too far out of range, otherwise left unchanged 

VB An octave below the actual voice/melody

VBAUTO An octave lower, if not too low, otherwise left unchanged

VA16 Two octaves higher

VB16 Two octaves lower

VA, VB Two voices: One an octave higher (VA) the other doubled below it (VB).

OK A placeholder. Leave this parameter unchanged.

3.5.5 Accompaniment Style

The style basically contains the rhythmic material used when Ludwig creates an
accompaniment for band. For example, the rhythm of the bass is often fixed, but the notes
(pitches) can be free, so Ludwig can compose an attractive bass line.
Examples of accompaniment styles are: Samba, Pop Ballad, Folk Rock.

Instrumentation and voicings however, come out of the arrangement . Some styles have
more than one arrangement. 

Styles are divided into drama stages  like "calm", "agitated, "climax". This creates contrast
and variety and enables you to control the emotional development of a piece.

3.5.6 Drama Stages

Styles, arrangements and storyboards  use drama stages. This helps to achieve emotional
developments in the composed arrangements.

Once you have assigned drama stages to the melody lines of your song in the storyboard ,
you can apply any style to it, and the resulting emotional development will be roughly
equivalent. Drama stages act as an abstraction to link an accompanying style and the
melody.

 List of Drama Stages

English Abbreviation Short in Style Editor Interpretation

Calm Calm Quiet, calm

Calm-2 Calm2
Calm, but with fills at the end to
create transitions.

Normal Norm Standard drama stage

53
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English Abbreviation Short in Style Editor Interpretation

Normal-2 Norm2
As above, but with fills at the end
to create transitions.

Agitated Agit Heightened feeling, agitation

Agitated-2 Agit2 As above, with filler/transition

Climax Clix Emotional high point.

Climax-2 Clix2 As above, with fillers.

Final Fin
Last line of a song, bringing the
arrangement to a conclusion.

Intro InMaj Intro

Outro OutMaj Outro

Solo/Break Solo Instrumental interlude

When Ludwig writes an accompaniment for a piece of music, the program progresses line by
line. The "style" determines the rhythmic texture for the accompaniment at a given drama
stage. The "arrangement" contains the instrumentation. 

3.5.7 Musical Genres

The accompaniment styles in Ludwig are grouped into genres. Examples of musical genres
in Ludwig include:

Jazz
Pop
Rock
Country
Klezmer
Dance
New Orleans

You can sort styles in the dialog box for the accompaniment style  or the dialog for Ludwig-
Songs  by genre.
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3.5.8 Editing Styles

Ludwig has an open style  format. Accompaniment styles are primarily text files. Creating
and editing styles is rather complicated - technically as well as musically - and involves
making a meta composition in a type of script language. 

You can safely ignore this section. This part of the manual forms part of the internal
documentation for the program.

Creative editing of arrangements  is much simpler to understand and gives you a lot of
control over the resulting compositions.

3.5.8.1 Creating a Style

The style determines what the rhythm section of a band plays. Designing a style looks
complicated at first sight, but with a little bit of work, you can start having fun with it after
mastering only the first few steps. Try out the Tutorial .

Before you start working with the style editor, you should be familiar with the arrangement
editor, that is you should have created arrangements  yourself.

Go to Applications Menu Date -> New -> Style, to create a new style.

Styles are stored in Documents\Ludwig\Styles. They are text files written in a simple scripting
language. Each style needs to have a unique title, from which its file name will be formed.
You can look at style files with a text editor like Windows Notepad.

Reference Style Editor
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3.5.8.2 Tutorial: Style Settings

Here's a step-by-step guide describing how to create a simple style, and how to combine it
with an arrangement.

 

New Arrangement

First, create a new arrangement, so you can use it for immediate tests with the new stylet.
Select Application Menu  > New > Arrangement.

Give it the title "Tutorial". Click 'Normal' below Drama on the left side:

26
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Enable piano, guitar1, bass, drums and percussion parts. This will be our instrumental cast
for the whole style, but for simplicity, we've only included one drama stage . Once the
arrangement is finished, click on OK. If you want to delete it later, you'll find it in My
Documents/Ludwig/Arrangements.

New Style

Now create a new style: Application Menu  > New > Style. Give it the title "Tutorial". Then
click on Add Arrangement and select "Tutorial". The new style will now be associated with
this arrangement. You can also create other arrangements (instrumentations) late and assign
them to this style.

Click on the Add Taste button and select, for example, POP and COUNTRY.

Set the tempo e.g. 130. Then click 'Ornaments' so the melody will be embellished.

59
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 General Style Settings

 

Bass

First, lets program the bass. Click on Bass > BassBars. Enter a simple rhythmic pattern
under 'Bass-Any': 1/2(B), 1/2(5).

We'll ignore the drama stages for the rest of this tutorial and just focus our attention on the
top line Any. The pattern in Any is used as placeholder for all drama stages which do not
have own entries.

 

 
This is a simple bass line, alternating between the root and the fifth. This is enough for the
start. 

Click on OK to exit the style editor. Open the composition dialog. Choose "Tutorial" as the
style. Arrangement "Tutorial" will be activated automatically, because we've assigned it to this
style. Use any rhythm and chords you like and listen to the result. Its' a fairly dull Trio (only
two instruments playing the melody), but its functional.
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More about Bass style editing here

Now reopen the style in the style-editor via Application Menu > Open > Style. We
recommended to learn the keyboard shortcut Ctrl-Q, because you'll have to open style quite
often for the remainder of this tutorial. 

 

Piano

Let the piano play in the gaps left by the bass, on beats 2 and 4. Click on Keyb RH and enter
the following under Keyb_RBars-Any: r1/4, 1/4, r1/4, 1/4

 

This rhythmic pattern begins with a quarter rest ("r1/4" 'rest' ), followed by a standard chord
on beat two, etc.

Now repeat the above steps to let Ludwig compose with this style - you'll notice it has
become a bit more lively. 

More about Keyboard RH here

Tip: In the style editor, pressing the Enter key once saves the style. If you press the Enter key
again, the composition dialog will open. 

 

Guitar

The guitar complements our band with a simple arpeggio. Click on guitar1, and under
Guitar1Bars-Any, enter: 1/8(A), 1/8(A), 1/8(A), 1/8(A), 1/8(A), 1/8(A), 1/8(A), 1/8(A)
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The (A) function stands for 'Arpeggio'. If you don't type in exactly eight eighths (Ctrl-C, Ctrl-V,
are useful here), the style editor will give you a warning about incomplete bars. A rhythm
pattern has to contain full bars.

In the example above, the eighths on beat two and four are accented. 

More about working with the guitar in style editor here

 

Drums

Now we'll take care of the drums by adding a bass drum, snare and hi-hat in one step:

Click on the Bass Drum and under Bass DrumBars-Any, type in: 3/8, 1/8, 1/4, r1/4

Click on Snare and enter r1/4, 1/4+1, r1/4, 1/4+3

The figures "+1" and "+3" delay the hit by about 1 and 3 milliseconds respectively. This
makes the snare play a bit "behind the beat", which gives a more realistic groove. 

Finally, click on Pulse and enter 1/8, 1/8, 1/8, 1/8, 1/8, 1/8, 1/8, 1/8

More about drum pattern editing here

 

We'll need to change the volume of the drums slightly:

Click on PulseDyn and set the first value on the left to 75. This is the global Midi-Velocity for
the hi-hat which we want to make slightly louder.

78

81



List of Functions 67

© 2011 ChessBase GmbH

Percussion

We want to round off our little band by adding a tambourine on beats two and four.

 

Click on Perc1 Midi and then on Add Drumkit voice. Search for 'Tambourine' in the list, then
click on OK. You can also experiment with other percussion instruments.

Then click on Perc1 and enter r1/4, 1/4, r1/4, 1/4

 

More about Percussion here 

 

That completes our mini-style. If you want to, you can extend the bass-pattern to cover two
bars, to get some variety: 1/2(B), 1/2(5) and then 1/2(B), 1/4, 1/4. Note how Ludwig then sets
the pitches of the two quarter notes by himself.

 

The next steps would then be to add, for example:

Various levels of drama stages .

Transitions and fills in drama stages with the "2" at the end.

A closing phrase in the bars of the drama stage "Fin".

Changes in the melody instruments, using fills, counter, duet, etc. in the arrangement.

Using Pad for background.

Intros and outros
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3.5.8.3 Style Editor -General Settings

 
The title of each style must be unique, as it will be used to build the file name. 

For Taste, choose one of the available predefined music Genres. Then the program can
assign chords and rhythms that suit this genre. Use the Add Taste button for this. 

The Arrange panel contains all the Arrangements that have been associated with this style
. Click on Add Arrangement if you want to add more.

The Meter is given in the form n, m, and is fixed for a given style. 

The Tempo set here will be the default tempo when you choose this style in the
composition dialog box.

Swing takes values like "50, 1" or "70,2". The first number is the percentage strength of the
Swing-Effects, i.e. the magnitude of the shift in eighth pairs. 100% means that the first
swinging eighth in a pair is twice as long as the second (exactly ternary). The second
number indicates whether the effect relates to an eighth or a sixteenth: 1 = ternary eighth
(classic Swing), 2 = ternary sixteenth.
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Ritardando denotes the strength of the final ritardando. So you can end pieces on the final
note of the melody without needing an additional Outro to end the song conclusively. Good
values to use are 40-60%

Fermata is a fermata on the final note of a melody. Range lies between 10-20%.

The Composition Engine can distinguish between the various music styles on the basis of
articulation, rhythmic ornamentation and emphasis. Jazz music features chromatic
melodies, Country music however, does not. Melody Spirit controls those parameters.

Ornaments decorate a melody. The ornaments are compatible with the genre selected
under Melody Spirit.

Bass Spirit is similar to Melody Spirit, but somewhat simpler.

Piano Sus Pedal uses the piano pedal to hold down a chord. This makes it sound a little
softer, but less precise. 

N Outro Bars Maj is the number of Outro bars in Major, Outro Bars Min is the number of
bars in Minor, the same as for the Intro. 

Make Outro is a tool, that sets all Outro-Patterns in 4/4 and generates a simple final chord
for the tune. You can also work without Outro.

Make Intro produces a Default-Intro by cloning the data from the drama stage 'Normal'.

 

3.5.8.4 Rhythmic-Patterns in Style Editor

A style can have a one-bar, two-bar or four-bar symmetry pattern for each Part in the rhythm
section (Git, Keyb, Bass, Drums). These normally vary for different drama stages  or
remain constant. For the Bass, implementation of pitches can either be left entirely to the
composition engine, or set fixed to certain chord notes ("Play the 5th of the chord on the 2nd
beat of the bar").

A rhythm consists of a note value, articulation, accents and micro-timing. 

You can also add a global dynamic to each part - for example, this sets the volume. 

Note values:

Rhythms consist of a series of note values: e.g. "1/4, 1/4, 1/4, 1/4"  (or "/4, /4, /4, /4" for short,
or "4, 4, 4, 4" even shorter).

In the example above the composition engine has to write four quarter notes, but is free to
choose the pitches or chords. Only full bars are allowed.

Articulation:

The articulation is controlled with the articulation symbols below: 
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 "1/8., 1/8., 1/8., 1/8., 1/8., 1/8., 1/8., 1/8." are all Staccato-Notes                  

 

Symbol Articulation

. Staccato

; Staccatissimo

: Breathe

~ Legato ("1/2~, 1/2~")

=

Tie: If the following note has
the same pitch (or is the
same chord) tie them
together across bar breaks.

_ Portato

p (Hold-)Pedal down

u Pedal release (up)

 

Accents:

Symbols for accents are placed before the note values, e.g. " 1̂/8, d1/16, g1/16., '1/8, d1/16,
g1/16., 1/2". Accents are important for a good groove.

Symbol Accent

* Crash-Accent, maximum

< Hit-accent, really strong

! Very strong

^ Strong accent

' Normal accent

° Weak accent

d Light damping 

s Damping

g
Strong damping ("ghost
note")
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r Pause ("rest")

 

"r4/4" is a bar rest.

 

Microtiming:

Micro timing helps to bring the right groove in advanced style design. It is used to slightly shift
the note ahead or behind of the 'mathematically' correct time point. Micro timing is indicated
by placing a "-" or "+" and a a single digit number behind the note value.

Example "1/4, 1/4+2, 1/4, 1/4+4" delays the second note by two milliseconds, and the fourth
note by four milliseconds. The effect is noticeable, and can e.g. be used to give a laid back
feel to a snare drum. A minus after the note value accelerates the note by the number of
milliseconds indicated by the digit. If no number is specified, a default value of five
milliseconds is used. For example, "1/4-, 1/4, 1/4-, 1/4" accelerates both the first and the third
note by five milliseconds. This gives the music an impulse forward. 

 

Functions:

Functions are written in brackets after the note value and after the articulation and micro
timing. Functions determine which pitch or chord the composition engine should set at this
point. If functions are omitted, the composer sets a default function. 

Example for the Bass: "1/4.(B), 1/4.(5), 1/4.(1), 1/4.(Chrom)" = Low fundamental of the chord
on the first beat, a fifth on the second beat, any fundamental on beat three, chromatic
passage on the four, all played staccato.

Repeating the Patterns:

If you only supply one bar for the pattern ( = "A"), this will be repeated four times ( = "AAAA").
For two bars ("AB") these will be repeated as ("ABAB").

Alternatively, you can use the shorthand "repA" or "repB" in the bar entry fields, and
specifically say where to repeat the first (repA) or second bar (repB):

Overlapping Notes:

Up to now, the duration of each note has been less than or equal to its value in the time grid.
A new note in a track will only be sounded when the previous note has finished. The Legato
articulation, however, provides a small overlap.

Larger degrees of overlap, which lead to polyphony in a track, have to be indicated using
special notation. You combine length in the time gridth and duration of sound by a "#". For
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example, 1/4#1/1 is a whole note, separated from the next note by a quarter (1/4). 0/1#1/4,
1/4#1/4 produces two quarter notes played simultaneously, because the grid length of the
first note is 0.

This notation is not really intuitive, because it doesn't correspond directly to classical notation.
You could also use it for non-overlapping notes: 1/4#1/16, would be a quarter note played for
a duration of 1/16th, that sounds like a staccato. However, the staccato notation "1/4." would
be more practical.

3.5.8.5 Dynamics Settings in Style Editor

In the Style Editor, you can adjust the dynamics (volume distribution) for each part using a set
of five parameters. You can either set this for the entire piece ("Any"), or for individual drama
stages .

The Dynamic settings are indicated by the suffix "Dyn", e.g. Bass Dyn controls the volume of
the Bass:

 

The five parameters of the dynamics setting:

Value Range Meaning

1. Volume 0-127 General Volume ("Midi Velocity")

2. Main Emphasis 0-100%
Emphasize the 1 (and in 4/4 the 3) in the
bar.

3. Accent Strength 0-100%
Influence of accents on the volume.
Accentuate/attenuates the Accents in
the Rhythm patterns.

4. Figuration 0-100%
Emphasis on the first note in a group of
notes, such as eighth pairs or 16th
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quads.

5. Random fluctuation 0-100%
Randomizes the value of the volume,
creating a human touch by a little bit of
imperfection.

 

It is usually sufficient and recommended to just set the Any-entry and ignore the different
drama stages unless you want to realize super-crescendos in your piece.

3.5.8.6 Drum Kit Midi Values in Style Editor

For all drum patterns you supply the midi values to determine which instrument of the drum
kit should be used.

The button Add Drumkit Voice switch adds a drum kit instrument. You can change the edit
field by typing, but the add button is recommended to get the correct names. Usually, you
only need to enter data in the first line (Drama=Any).

For each drum there are eight different instruments possible each with its own Midi Value. A
number in round brackets behind the note value determines which instrument is played at
which position in the pattern.

Example:
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The Drum Kit instruments are: HighFloorTom, LowTom, LowMidTom, HighTom

 

So a Pattern looks like this:

"1/8, 1/8, °1/8(2), 1/8(2), °1/8(3), d1/16(3), g1/16(3), '1/4(4)"

The first two eighth notes have no Function in brackets, they use the default values, that is
the first instrument, the HighFloorTom (default =(1)).

The LowTom plays on the next eighth notes ( Function = (2) ), then the LowMidTom
( Function = (3) ) and on the last quarter, with Accent, the HighTom.

3.5.8.7 Associating an Arrangement with a Style

Usually, an arrangement is associated with one or more styles - but not every type of
instrumentation is suitable for every style.

 

On the 'General' page of the style editor, there's an add arrangement button. This gives you a
list of all the arrangements at your disposal. Choose the arrangement from this list that you
want to be permanently associated with that style.

Your choice will then appear in the composition dialog box whenever you click on that style:
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Note that there are four arrangements associated with the style Combo Swing. The selected
style Jazz Quartet further offers a wide choice of instrumentations.

3.5.8.8 General Arpeggio

The Keyboard, Guitar and Phrases have general arpeggio functions which can either specify
chord notes or parts of chords: 

These functions optionally have extra parameters after a separating colon (":"). The first
parameter n indicates that the chord is played in the n-th inversion. If you leave the colon out,
Ludwig will assume a value of 0 by default. The ground position of the chord is given by the
associated range for the part.
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Function Explanation Example

iC:n Chord, inverted n-times.
1/4(iC:0), 1/4(iC:1), 1/4(iC:2),
1/4(iC:3) resulting in an
ascending Chord-Arpeggio

iHN:n
Highest note of n-times
inverted chord.

1/4(iHN:0), 1/4(iC:0), ...

iLN:n
Lowest note in n-times
inverted chord.

1/4/(iLN:0), ..

iU:n
Upper Part of Chord (two ore
more notes)

1/4(iU:0), 1/4(iL:0)

iL:n Lower Part of Chord 1/4(iHN:1), 1/4(iL:1)

iO:n
Outer Part, i.e. highest and
lowest note.

 

iO3:n
A voicing with only three
notes, easy to play on a
piano.

1/4(iO3:1)

iIN:n Inner Part  

iN:n
Upper Neighbor. Good for
ornaments in finger picking
styles.

1/8(iHN), 1/8(iN), 3/4(iC)

iW:n Lower Neighbor 1/8(iHN), 1/8(iW), 3/4(iC)

iA:n
General Arpeggio, will not
break across chord changes.

8(iA:0), 8(iA:1), 8(iA:2), 8
(iA:3), 8(iA:2), 8(iA:1), 8(iA:0),
8(iA:1)

iSD:n
Arpeggio in sawtooth form,
descending

1/8(iSD:0), 1/8(iSD:1), 1/8
(iSD:2), 1/8(iSD:3), ....

iSU:n
Arpeggio in sawtooth form,
ascending

 

iR:n Run. 1/16(iR:0), 1/16(iR:1), ....

iJU:n

Arpeggio: move n chord
steps upwards. N.B. the 'n'
here is not the chord
inversion but the number of

1/4(iU:1), 1/4(iU:1), 1/4(iU1)
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chord steps in the jump.

iJD:n
Arpeggio: move n chord
steps downwards.

1/4(iJD:3)

iV15:n

A fifth, if contained in the
chord ("PowerChord"). If
there is no fifth, use an
available fourth. Good for
Rock.

1/4(iV15:2)

iKL:n
Keyless. Chord without a
root.

1/1(iKL:1)

 

Tip: For long patterns, simplify 1/4(iA:n) to 4(iA:n) or 1/8(iA:n) to 8(iA:n).

All the examples given above are written without accents or articulation. You need different
accents, to create realistic grooves.

3.5.8.9 Bass in the Style Editor

For the Bass, it's sufficient to set a simple Rhythm pattern, and allow the composition engine
to decide about the individual pitches. The result is a bass line of melodic indepence, which
adapts itself to the shape of the main melody. "4, 4, 8, 8" for example, would be a valid bass
pattern in 3/4 time.

A Bass with a strong melodic indepence isn't suitable for all styles. So you can fix certain
notes to given pitches.  Often that would be only the root of the chord.

Function Meaning Example

B Lowest root tone of a chord 1/2(B), 1/2(5)

H Highest root tone of a chord
(only if possible within the
range)

1/4.(B), 1/4.(H), 1/4.(B), 1/4.
(H)

1 Any root possible in the range '3/4(1), 1/4(5)

5 Any fifth of a chord possible
in the given range.

4/4(5)

5L Prefer a lower high fifth. 4/4(5L)

5H Prefer a higher fifth. 4/4(5H)

6 Sixth 1/2(B), 1/4(5), 1/4(6)
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Function Meaning Example

4 Fourth 1/2(H), 1/4(4), 1/5(5)

3 Third 1/2(B), 1/4(3), 1/4(5)

2, 9 Major second or ninth of a
chord

1/2(B), 1/4(2), 1/4(3)

A Anticipation of the following
root across the bar break,
vital for pop&rock styles.
Good for the last eight of a
bar.

1/4(B),1/4;(H),r1/8,1/8;(5),
r1/8,'1/8=(A)

Chrom Chromatic passage (jump) 1/2(B), 1/4(Chrom), 1/4(5)

ChromU, ChromL Chromatic with a jump from
below or above

1/4, 1/4, 1/8, 1/8(ChromL),
1/4

R Repeat last note. 3/8(B), 1/8(B), 1/2(B)

RC Ascending chromatic
passage running to the next
chord tone. Scale tones are
numbered increasing from 1
to 7.

1/2, 1/8, 1/4(RC:-3), 1/4(RC:-
2), 1/4(RC:-1)

FC Descending chromatic run,
scale tone numbers
decreasing from 7 to 1.

1/4(FC:3), 1/4(FC:2), 1/4
(FC:1)

RR Ascending scale run 1/4(RR:-3), 1/4(RR:-2), 1/4
(RR:-1)

FR Descending scale run 1/4(FR:3), 1/4(FR:2), 1/4
(FR:1)

 

 

3.5.8.10 Guitar in the Style Editor

Ludwig styles have two guitar parts. If more guitars are required, you can use the Phrases.
For guitar tracks, the chords are set in a way so that they can be played on a real instrument.

A pure Rhythm Pattern without functions will lead to strummed chords. So even with a simple
pattern like r1/4, 1/4, r1/4, 1/4 you can achieve some results.

There are some special guitar functions, but you might find it more useful to program piano,
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guitar and phrases with the general arpeggio , it is more general and all in all less to learn.

Special guitar functions:

Function Explanation Example

B Low chord root.
1/4(B), 1/4(UC), 1/4(5), 1/4
(UC) (result in a "Boomchick"-
backing accompaniment)

5 Fifth of the chord. see above

UC

Upper Chord. The chord is
played (strummed) using the
higher strings. Sounds good
in alternation with the "B".

see above

LC
Lower Chord. Play the lower
strings of the chord.

1/4(LC), 1/4(UC), ...

UT
Upper Chord with inner
tension. Good for pop.

4/4(UT)

FS
Full Strum. Play the chord on
all strings

1/4s(FS), 1/4s(FS), ...

PC Power Chord. Bass and fifth. 4/4(PC)

PC6
Power Chord with bass and
sixth.

 

5D

Hammer down five. Approach
the fifth from above, must
occur in pairs. Good for
Country-picking.

1/8(5D), 1/8(5D), ....

3U
Approach the third from
below, must occur in pairs.

1/8(3U), 1/8(3U), ...

A
Simple arpeggio from below.
Realistic picking, starting
from the bass tone.

1/8(A), 1/8(A), ...

AU Simple arpeggio from above. 1/8(AU), 1/8(AU), ...

a
Anticipation of the next chord,
an important Rock-style

1/4, 1/4, 1/4, 1/8, 1/8=(a)

If you attach an ":a", e.g. "(B:a)", the function will operate on the next chord (anticipation).
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Again: the Guitar can use the general Arpeggio-Functions

 

Playing Technique: rhythm patterns for the Guitar support two additional articulations: 

Articulation Explanation Example

s
Strum: strings are hit in
succession, one after the
other

1/2s(FC), 1/2s(FC)

&

Ring: Using the sustain pedal
for the duration of the chord
sounds like a different guitar
sound.

1/2&(FC), 1/2&(FC)

 

If the Guitar only plays chords, it will be represented in the score in rhythm notation.

3.5.8.11 Keyboard in the Style Editor (Left Hand)

The piano is divided into 'Piano LH' and 'Piano RH', which represent the left and right hands
respectively, which are dealt with individually.

Piano Right Hand

The left hand follows its own rhythm pattern, but the pitches are defined by the pitch of the
bass  note that's being played at the same time. The piano also acts as the left hand of the
bass, although it can play rhythms by itself (though this is not always a good idea).

Thus, the left hand of the piano is used mainly to reinforce the bass lines.

3.5.8.12 Keyboard in the Style Editor (Right Hand)

The Piano is divided into Piano LH and Piano RH, that is, the left Hand and right Hand.

Keyboard Left Hand .

 

If you enter a simple rhythm pattern for keyboard RH, Ludwig will write standard
accompaniment chords with proper voice leading. The pattern "4/4" will e.g. create the most
simple piano background possible: full bar chords.

It is recommended that you use the general arpeggio  for the right hand piano. This has the
advantage of being compatible with guitar or phrase tracks.

There are also some special piano functions which also might come handy:
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Function Explanation Example

C Chord (Default) 4(C), 4(C), 2(C)

U
Upper Part. Chord without the
lowest note.

1/2(U), 1/2(L)

L
Lower Part. Chord without
the highest note.

1/2(U), 1/2(L)

O
Outer Part. Inner notes are
missing.

4/4(O)

YN
Inner Part. Outer notes are
missing.

4/4(YN)

HN Highest Note. 1/4(HN), 1/4(L), 1/2

LN Lowest Note. 1/4(HN), 1/4(LN), 1/2

T
Tensed Chord. Chord with
"inner tension", e.g D-E-G
instead of C-E-G for C major.

1/4(T), 1/4(T), ...

TL
Lowest Note of a chord with
tension.

1/8(TU), 1/8(TL), ...

TU
Upper Part of a chord with
tension.

 

AT
Arpeggio from Top. Simple
automatic Arpeggio.

1/8(AT), 1/8(AT), ...

R
Run with the root as the
target note. The steps are
diatonic in the chord scale.

1/4(R:3), 1/4(R:2), 1/4(R:1),
1/4(R:0).

Suitable for dominant runs

CR
Chromatic Run with the
chord root as the target note.

1/8(CR:-4), 1/8(CR:-3), 1/8
(CR:-2), 1/8(CR:-1), 1/2
(CR:0)

 

 

3.5.8.13 Drums in the Style Editor

The Drumkit is divided into Drums and Percussion, each have their own channel in the mixer
.

When editing styles you have four drum and five separate percussion tracks.

Drum tracks:
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Pulse (usually a HiHat)

Pulse2 (additional HiHat or Cymbal track)

Snare

Toms

On the Midi Pages , you can assign different instruments to the Drum Tracks. One track
can have between one and eight instruments, but these can't be played simultaneously on
the same track.

A simple pattern for the Bass-Drum:

1/4, r1/4, 1/4, r1/4 or 3/8, 1/8, 1/2

A simple pattern for the Snare (with micro-timing to play slightly behind the beat)

r1/4, 1/4+2, r1/4, 1/4+3

Eighths for the Closed HiHat, with final quarter note on the Open HiHat:

°1/8, d1/8, °1/8, d1/8, °1/8, d1/8, 1̂/4(2)

3.5.8.14 Percussion in the Style Editor

The Drumkit is divided into Drums and Percussion, each have their own channel in the mixer
.

There are five percussion tracks:

Perc1

Perc2

Deco1

Deco2

Deco3

On the Midi Pages , you can assign different instruments to the Drum Tracks. One track
can have between one and eight instruments, but these can't be played simultaneously on
the same track.

3.5.8.15 Phrases in the Style Editor

Phrases are rhythmic patterns, based on chords or arpeggios. There can be up to four
phrase parts in a style. 
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For each of these four phrase parts, there's a pattern page with the rhythmic definitions, a
volume page (Dyn) and the range page. In the range values, C5 corresponds to middle C on
the piano.

You also have a Type page, which controls which chord types are used for building the
chords of the phrases:

 

Blocks are chords in the closed position, what you would play with the right hand on the
piano.

Drop2 are chords in an open position. The chord notes are distributed over a wider range.

ChordNote is the root of the chord.

Pedal is the root of the overall scale key used.

Typically, Blocks will be used.

 

Phrases are normally simple rhythmic patterns, and might have strong accents.

You can program phrases with the general arpeggio  functions. This is recommened,
because once you master the general arpeggio, you can use it for piano and guitar as well.

Here are some simplified functions for quick pattern writing: 

Function Explanation Example

C Chord (Default) 4(C), 4(C), 2(C)

B Bass Tone 4/4(B)

5 (or 1, 2, 3, 4, 6, 7, 9) Fifth (or other Chord Tone)  

A Simple Arpeggio 1/4(A), 1/4(A), 1/4(A), 1/4(A)

H High chord fundamental 4/4(H)

T

Topnote (highest note of the
current chord). Ludwig does
proper voice leading when
implementing chords, so a
part with the highest note
only will not make big jumps.

1/4(T), ...

T2
Top2 notes. Nice effect with
high-range strings.

4/4(T2)
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P
Second highest (penultimate)
note in a chord

1/4(T), 1/4(P), 1/2(T)

ChA Alt-Part for a Choir 1/2(ChA), 1/2(ChA)

ChT Tenor-Part for a Choir 4/4(ChT)

ChB Bass-Part of a Choir 4/4(ChB)

 

You can express chromatic approaches for full chords: one of the parameters in the 
Function clip must have the form d1 or u1, e.g. 1/4(iC:0:d1), 1/4(iC:0) produces a chromatic
approach from below ("down 1") on the following chord. 

Example: "r1/2, r1/8, 1/8(iO), 1/8(iO:0:d1), 1/16(iO), r1/16" is a nice chromatic changing motif,
e.g. for a Flugelhorn. Instead of using a full chord, it only uses the outer notes.

You can add ":a" to each function to make it anticipate the next chord, e.g. "(B:a)". Useful for
the last function in a bar.

3.5.8.16 Pad in the Style Editor

Pad is the harmonic background, and should not have rhythmic accents. As with Phrases ,
you can set a range for the pitches used in the Pad.

 

The following expression produces "High Strings", an ethereal, high note on the strings: "4/4=
(T)".

The Type must be Blocks (Drop2 would also be OK). The Range is set to G7 to G8. In range
values, C5 corresponds to middle C on the piano.

Pad recognizes these functions:

 

Function Explanation Example

T Top. The highest note. 4/4=(T)

T2 Top2. The highest two notes. 4/4=(T2)

 Note the trailing "=" symbol. This means that notes are tied across bars if the voice leading
keeps them identical.

If no function is given, you'll hear simple chords.
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3.5.8.17 Anticipations in the Style Editor

Anticipations are chord notes from the next chord, which might create a brief dissonance to
the current chord. This dissonance is then resolved when the next chord sounds. This is a
typical element in Pop and Rock.

An example of an Anticipation for the guitar: 1/4, 1/4, 1/4, 1/8, '1/8=(a)

This means there are four chords struck on the four beats of the bar. On the last eighth
("four-and") the chord changes to the next chord, which belongs to the first beat of the next
bar. The sign "=" after the 1/8 means that this chord should be tied across the bar break into
the next chord. Note the accent on the anticipation.

 If you look at the "LK Rock" style in Style Editor, you'll find its full of piano, guitar and bass
phrases containing anticipations.
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3.6 Output

3.6.1 Printing

Printing Sheet Music

Applications Menu  > Print > Print Parts.

Prints out a selection of parts from the full score. If the score contains repetitions, like, for
example, verses, these will either be omitted, or denoted by a repeats sign. 

Before printing, you're always shown a print preview, which you can cancel by clicking on the
red cross in the center of the menu bar.

Print Melody

Applications Menu  > Print > Melody.

Prints the melody that you've input, as it is displayed, line by line. If you want to print a song in
the form determined by the storyboard , you can compose any accompaniment, and then
print one ore more melody parts from the score with the above function.

Page Setup

Applications Menu  > Print > Printer

Sets the page margins.

Printer Setup

Applications  Menu > Print > Printer Setup.

Printer settings valid for the duration of the program session.

3.6.2 Recording in MP3 Format

Ludwig stores finished Compositions (Scores) as MP3 files. To get an an MP3 file, you need
to record the whole composition.

Select Applications Menu > Save As > Record MP3.

Click on Record.
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After Ludwig has finished playing/recording, you should see a wave pattern like the above in
the recording window. The left stereo channel should be at the top, the right channel
underneath. If not, your audio recording devices are not configured correctly. 
Click on Save (MP3).

You can also save your data as a WAV file, if, for example, you want to write directly to CD.

3.6.3 Export Formats

Midi Export

Application Menu  > Save As > Midi Format..

Depending whether you have selected the melody editor tab or the score tab, the melody or
the full score will be exported as a MIDI file.

The MIDI-format is probably the most widely used data format to exchange music data
between different programs.

MusicXML Export

Applications Menu  > Save As> MusicXML.

Depending on whether you've got the melody or the score open, the former or latter will be
exported as a MusicXML-file.

The MusicXML-format is a standard format for data exchanges between music software
programs. It is more versatile and precise than the MIDI format and especially suited if you
want to export a Ludwig score for further processing in a notation software package.
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3.7 Playing Music

3.7.1 Managing Playlists

Playlists are lists of Ludwig-Songs  that can be played back in a random order to generate
background music. 

Tab Play > Playlist > Open Playlist:

When Repeat is selected at the top right, the music will play indefinitely. If you want the songs
to be played in the order of the list, unselect Shuffle. When Ludwig plays songs from a play
list, the entire list will be processed before one song repeats. A repeated song is not
necessarily the same song. As you can see in the screen shot above, You can specify
RANDOM parameters for rhythm and chords.

3.7.2 Concert

A concert is a sequence of preselected Ludwig-songs  on which you improvise. The
underlying playlist  controls the order in which the songs are played.

Use Play  > Options > Concert.
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3.7.3 Sessions with an Eight Bar Theme

Select Play > Options > Interactive Session.

The interactive session is a fun feature for advanced musicians. You enter an eight bar
theme via MIDI and Ludwig responds to it in real time.

The feature practices spontaneous invention of eight bar themes. This is easier than it
sounds and an interesting musical ability to train. Improvising on the piano for example,
sounds much better if you are thinking in terms of melodic phrase (rather just performing
outputting patterns on autopilot!).

If you have a reasonably strong machine, Ludwig will respond to your theme more or less in
real time. Don't worry if Ludwig already shows activity after four bars, because the program
has to start calculating whilst you're playing.

The end result will be a piece of 32 Bars + Intro consisting of variations of your original theme.

Ludwig needs to recognize the key your theme is written in. It usually succeeds for an eight
bar theme. By using little tricks, like ending the theme on the root of the tonic or by using
some arpeggios on main chord functions, you can make it easier for the program to "find" the
right key. 

Connect your Midi-keyboard, connect Midi-Out of the keyboard to Midi-In on your computer
Midi cable.
Select tab Play > Options > Interactive Session.

Enter a time signature (meter).

Choose an accompaniment style for the band. For the beginning a very slow style is
recommended until you get the hang of it.
Test the MIDI connection, the rectangle in the dialog should be flashing green.

Click on Start Input. Start playing on the correct beat. It is no problem if you leave out a
couple of empty bars from the metronome. 
The black window will show the bar numbers. After eight bars, Ludwig will start to play,
whether you're still playing or not.
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You may find it easier to invent themes in 3/4 time as they're shorter. Slow Swing Waltz
is a good choice for a start.
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4 Support

4.1 FAQ

Who holds the rights to Ludwig compositions?

Ludwig compositions are not subject to Copyright protection, unless any of the melodies you
import or enter are affected by the rights of a third party. The manufacturers of Ludwig don't
claim Copyright over any of the music created using their software.

How do I set up a piece for just one melody instrument plus accompaniment? 

Create an ensemble  for a single instrument only. At the bottom of the ensemble-dialog,
tick all of the style functions, so that you get the full band accompaniment.

Can I input polyphonic scores?

The melody editor is currently limited to monophonic pieces. The full scores Ludwig creates
by himself can't be edited. You can however export these scores to one of the many excellent
notation software programs on the market, for further editing. Export the score as a MIDI- or
MusicXML-file .

9
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4.2 Troubleshooting

No Sound 

You might have accidentally loaded the wrong sound driver. Select the Tab Sound -> Sound/
Midi > Reset Sound/Midi Configuration.

The record function isn't working

Please check that the default recording device under Windows is set to Stereo Mix or
What you hear. More importantly, check that the microphone is not set as recording device.

Playback is uneven ("jerky")

Your computer isn't powerful enough to compose and playback simultaneously. Try to switch
off playing while composing: Make sure you've turned Applications Menu > Options > Search
Time > Start playing while still composing.
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4.3 Program Add-Ons and Updates

Visit the Ludwig website www.write-music.com, to find out about new versions of the
program and information about add-on products.

The program has an automatic update function: go to Applications Menu  > Activation >
Program-Update.

You can alternatively simply download and install the latest version from www.write-music.
com.
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